Is it possible to run RML-Image on a JVM older than v1.5?

No. You need to have a JVM v1.5 or higher to run RML-Image. Knowing that this can be a limitation for some users, I am presently evaluating a way to get around this.